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  Introduction 

1.1. About this document 

This document is a manual for creating scenarios that work in cooperation with 

WinActorEye. 

WinActorEye is a tool to search for a target image with high accuracy by combining 

image matching under relatively simple conditions while checking the result after 

performing a selected filter processing. By combining with scenarios of WinActor, you 

can operate the mouse for the coordinate information of the target image.  

In Chapter 2, you will create a scenario to click the "submit" button on the page where 

the WinActor sample file "Tutorial.html" is opened in Microsoft Edge (hereinafter, 

Tutorial page). Through the tutorial in this manual, you can learn the functions of 

WinActorEye. 

For how to use WinActorEye, see the material No.4 in Table 4.1-1 in "4.1Reference 

materials."  

 

1.2. Trademarks 

The names described below and other names of companies and products in this 

document are trademarks or registered trademarks of their respective companies. The 

TM, È, and É marks are omitted in this document. 

 

 Windows, Microsoft .NET Framework, and Microsoft Edge are trademarks or 
registered trademarks of Microsoft Corporation in the United States and other 
countries.  

* The official name of Windows is Microsoft Windows Operating System. 

 

  



 

2 

WinActorEye  Scenario Creation Manual 

1.3. Notes on this manual 

 The copyright notice "Copyright É 2013-2025 NTT, Inc. & NTT ADVANCED 
TECHNOLOGY CORPORATION" attached to this manual and the provided 
software cannot be changed or deleted. 
The copyright of this manual belongs to NTT, Inc. and NTT ADVANCED 
TECHNOLOGY CORPORATION.  

 

 The descriptions in this manual assume that users understand Windows 
operations and functions. For information that is not described in this manual, 
see the documents provided by Microsoft.  
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  Scenario creation tutorial 

2.1. Structure and operation of a scenario 

The structure and operation of a scenario to be created are shown below. 

You will create a scenario to click the "submit" button on the Tutorial page (inside the 

red frame in Figure 2.1-1). 

By changing a name of a subroutine called in "Call preprocessing subroutine" in the 

scenario, you can switch between a histogram search and a search using the OCR tool.  

 

 

Figure 2.1-1. Tutorial page 
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[Files for the scenario to be created] 

Create the files shown in Table 2.1-1 in the same folder on the computer where 

WinActor runs. 

In this tutorial, the folder that stores the scenario is "C:\EyeSample." 

 

Table 2.1-1. Description of each file 

No. Filename Description 

ᵑ  Eye_Hist_OCR_Sample.ums7 This is a WinActor scenario to be created in this 

tutorial. Here, the scenario with WinActor Ver.7 

is used as an example. 

ᵒ  Histogram_Search.json This is a WinActorEye macro to be created in 

this tutorial. It runs a histogram search to search 

for the "submit" button on the Tutorial page.  

ᵓ  Run_MSOCR.json This is a WinActorEye macro to be created in 

this tutorial. It uses the OCR tool to get the 

string and coordinate information in the Tutorial 

page. 

ᵔ  Search_submit.json This is a WinActor Note macro to be created in 

this tutorial. It searches whether "submit" on the 

Tutorial page exists in the processing result of 

OCR tool. 

ᵕ  Submit_Reference_Image.png This is an image file to be created in this tutorial. 

In the macro of No.ᵒ, the position of the 

"submit" button will be searched from the 

targeted Tutorial page based on this image. 

ᵖ  Tutorial.html Copy this file from WinActor_Documents in 

advance. 

 

In the scenario to be created in this tutorial, you will use the nodes and user libraries of 

WinActor as well as WinActor Note. For details of the nodes and user libraries in the 

scenario, see the materials No.2 and 3 in Table 4.1-1 in "4.1Reference materials." For 

details of WinActor Note, see the materials No.5 and 6 in Table 4.1-1 in "4.1Reference 

materials."  
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2.2. Scenario overview 

The overview of how to create the scenario is as follows. 

1. Creating the WinActorEye macro for the histogram search (see Section 2.5) 

A) Capturing the Tutorial page 

B) Creating and calling the "submit" reference image 

C) Calling the histogram search 

D) Converting the rectangle resource to the coordinate resource 

2. Creating the WinActor scenario for the histogram search (see Section 2.6) 

A) Creating the outline of processing 

B) Creating the histogram search preprocessing subroutine 

C) Creating the subroutine for getting coordinate information and operating the 

mouse 

3. Creating the WinActorEye macro for the OCR tool (see Section 2.7 and 2.8) 

A) Capturing the Tutorial page 

B) Calling the OCR tool 

C) Converting the rectangle resource to the coordinate resource 

D) Clearing the window and pasting from the clipboard  

E) Removing spaces from characters 

F) Searching for "submit" 

4. Creating the WinActor scenario for the OCR tool (see section 2.9) 

A) Creating the OCR tool preprocessing subroutine 
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2.3. Note 

You may not be able to find the targeted image even by following the steps in this 

manual. In that case, adjust the size and display font of the target Tutorial page or the 

parameters of each WinActorEye macro.  

 

2.4. Preparation 

Open the sample file "Tutorial.html" in Microsoft Edge before creating the scenario.  

For the procedure, see the material No.2 in Table 4.1-1 in "4.1 Reference materials." 
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2.5. Creating the WinActorEye macro for the histogram search 

For the operation of WinActorEye, see the material No.4 in Table 4.1-1 in "4.1 

Reference materials." 

The steps with "*" in the subsection title are subject to the macro recording.  

Launch WinActorEye and select [View] > [WinActorEye edit macro] to display the "Edit 

macro" pane. 

 Click the "Record" icon on the Edit macro pane to enable the macro recording. (The 

state of the red frame ᵑ in Figure 2.5-1 is the recording state. If it is not in the 

recording state as shown in the red frame ᵒ, click the icon in the red frame.) 

 

 

 

 

Figure 2.5-1. WinActorEye at the start of macro creation ᵑ 
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Or, select the "Edit macro" tab in the resource area to display the "Edit macro" pane, 

and click the "Record" icon on the Edit macro pane. (Figure 2.5-2  

 

 

 

Figure 2.5-2. WinActorEye at the start of macro creation ᵒ 
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2.5.1. Capturing the Tutorial page* 

Select [Input] > [Snapshot] to display the "Snapshot" property window.  

 

 

Figure 2.5-3. Selecting "Snapshot" from the menu 
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Click ᵑ of Figure 2.5-4 and then click Microsoft Edge with the Tutorial page displayed. 

The window title is set as shown in o . Then, click the button ɔ . 

After this step, click the "Record" icon in the "Edit macro" pane in Figure 2.5-1. 

WinActorEye at the start of macro creation ᵑ to disable the macro recording.  

 

 

Figure 2.5-4. Selecting the "Tutorial" page window 
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The window of "Tutorial" page will be displayed on WinActorEye as shown in Figure 2.5-5. 

 

 

Figure 2.5-5. WinActorEye window 
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2.5.2. Creating the "submit" button reference image 

To make the submit button as a target for the search, create a reference image for the 

submit button. 

On the WinActorEye window, click and hold the left mouse button on the upper left of 

the submit button, move the mouse to the lower right of the submit button, and then 

release the left mouse button. You can select a range with this operation. 

 

 

Figure 2.5-6. Selecting the range of the submit button 
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Select [Edit image] > [Trim] to display the "Trim" property window.  

Click the  button on the right edge of ᵑ and select "Tutorial - Profile 1 - Microsoft 

Edge." Select "MAIN" in o, enter "Submit" in ᵓ, and click the Execute button of ᴖ .  

 

 

 

 

Figure 2.5-7. "Trim" property window 
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Next, select [Output] > [Output image] to display the "Output image" property window.  

Click the  button of ᵑ and select "Submit." Click "Browse file" of o, and in the 

"Save" window, select "C:\EyeSample," enter "Submit_Reference_Image" for the 

filename, and click the Save button. Then, click the Execute button of ɔ. 
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Figure 2.5-8. Outputting the image 
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2.5.3. Calling the "submit" button reference image* 

Click the "Record" icon in the "Edit macro" pane in Figure 2.5-1. WinActorEye at the 

start of macro creation ᵑ to enable the macro recording. 

Select [Input] > [Input image] to display the "Input image" property window.  

Click "Browse file" of ŋ and select "C:\EyeSample\Submit_Reference_Image.png." 

Check the box of "Do not record the workFolder change into macro." (o ), and then click 

the Execute button of ɔ. 

 

 

 

Figure 2.5-9. "Input image" property window 
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2.5.4. Calling the histogram search* 

Select [Filter] > [Histogram search] to display the "Histogram search" property window.  

Click each  button of ᵑ and o, and select "Tutorial - Profile 1 ï Microsoft Edge" for 

ᵑ and "Submit_Reference_Image.png" for ᵒ. Enter "hist" for both ᵓ and ᴖ, and 

then click the Execute button of ᴗ. Based on the settings above, the location of the 

target image will be searched from the "Tutorial - Profile 1 - Microsoft Edge" image 

resource according to the information of "Submit_Reference_Image.png," and the 

information will be output to the rectangle resource specified in ᵔ. 

 

 

   

Figure 2.5-10. "Histogram search" property window   
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2.5.5. Converting the rectangle resource to the coordinate resource* 

Lastly, convert the rectangle resource of the targeted image to the coordinate resource 

to get the coordinate information of the targeted image. 

Select [Filter] > [Extract coordinates from rectangle] to display the "Extract coordinates 

from rectangle" property window. Click the  button of ŋ and select "hist." Enter 

"Coordinate resource output" in ᵒ, and then click the Execute button of ɔ .  

 

 

 

Figure 2.5-11. "Extract coordinates from rectangle" property window 
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Next, save the created macro. 

In the "Edit macro" pane, click the "Record" icon ŋ  and then click the Save icon o  to 

save the created macro to "C:\EyeSample\Histogram_Search.json." 

 

 

 

Figure 2.5-12. Saving the macro 
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2.5.6. Checking the operations 

Check the operations of the macro created so far. 

Click [Settings] > [Clear all resources] to initialize WinActorEye. 

 

Figure 2.5-13. Clearing all resources 

 

Next, open the saved macro. Click the "Open" icon ᵑ  and select 

"C:\EyeSample\Histogram_Search.json." Click the "Run all" icon o  to run the macro. 

 

 

Figure 2.5-14. Opening the macro 
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Check the result of running the macro. Select [View] > [Image resource] to display the 

Image resource pane.  

Click No.1 in the Image resource pane.  

 

 

 

  

Figure 2.5-15. Selecting the image resource to be displayed ŋ  
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Or, select the "Image resource" tab in the resource area to display the Image 

resource pane, and then click No.1 in the Image resource pane. (Figure 2.5-16). 

 

 

 

Figure 2.5-16. Selecting the image resource to be displayed o  
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The operations are successful if a red circle is displayed on the submit button in the 

WinActorEye window as shown in Figure 2.5-17.  

 

 

Figure 2.5-17. Expected result 
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2.6. Creating the WinActor scenario for the histogram search 

In WinActor, create the scenario for clicking the submit button on the Tutorial page by 

using the library that runs the macro created in Section 2.5.  

 

2.6.1. Creating the outline of processing 

Create the outline of the processing to call the individual processing performed by the 

WinActorEye macro as a preprocessing subroutine and the processing to call the 

common processing of mouse clicking based on the coordinate information acquired 

from WinActorEye as a post-processing subroutine.  

First, fix the position and size of the window of the Tutorial page so that the operation 

will be stable.  

Drag and drop "Window_SetWindowRectangle" from the Library tab. 

 

 

Figure 2.6-1. Placing the "Window_SetWindowRectangle" library 
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Set the property values according to the table below. 

Table 2.6-1. Property settings 

Item Setting value Remarks 

WinID name Tutorial - Profile 1 - Microsoft 

Edge 

Click the icon in the blue frame in 

Figure 2.6-2 and select the 

window of the Tutorial page. 

Upper_left(x) Value=>0 Select "Value=>" and enter the 

value to the right of "Value=>."  Upper_left(y) Value=>0 

Horizontal_width Value=>566 

Vertical_height Value=>558 

 

 

Figure 2.6-2. Setting the WinID name 
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Save the scenario once at this point. 

To save the scenario, select [File] > [Save as], set "C:\EyeSample" for the destination 

and "Eye_Hist_OCR_Sample" for the filename. 

 

 

Figure 2.6-3. Saving the scenario 
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Next, bring the window of the Tutorial page to the front so that it can be captured in 

WinActorEye.  

Drag and drop "Window_BringWindowToTop" from the Library tab. 

 

 

Figure 2.6-4. Placing the "Window_BringWindowToTop" library 

 

Set the property value according to the table below. 

Table 2.6-2. Property setting 

Item Setting value Remarks 

WinID name Tutorial - Profile 1 - Microsoft 

Edge 

Select from the drop-down list. 
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Next, call the subroutine for preprocessing. 

Drag and drop "Call Subroutine" from the Node tab. 

 

 

Figure 2.6-5. Placing the "Call Subroutine" node 
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Add a decision group so that the processing result of the subroutine for preprocessing 

can be judged.  

Drag and drop "Decision" from the Node tab. 

 

 

Figure 2.6-6. Placing the "Decision" node 
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Click the óEditô button of the property window and set the conditional expression 

according to the table below. 

Table 2.6-3. Conditional expression settings 

Item Left-hand side Comparison operator Right-hand side 

Setting value Processing_result is equal to Value=>OK 

Remarks - - Select "Value=>" and 

enter the value to the 

right of "Value=>." 
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Call the subroutine for post-processing. 

Drag and drop "Call Subroutine" from the Node tab. 

 

 

Figure 2.6-7. Placing the "Call Subroutine" node 
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2.6.2. Creating the histogram search preprocessing subroutine 

Create the processing specific to the histogram search as a preprocessing subroutine. 

Drag and drop "Subroutine Group" from the Node tab. 

 

 

Figure 2.6-8. Placing the "Subroutine Group" node 

 

Set the property value according to the table below. 

 

Table 2.6-4. Property setting 

Item Setting value Remarks 

Name Histogram search preprocessing - 
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Add the processing for reading and running the macro for the histogram search. 

Drag and drop "Eye_ReadAndRunMacro" from the Library tab.  

 

 

Figure 2.6-9. Placing the "Eye_ReadAndRunMacro" library 

 

Set the property value according to the table below. 

 

Table 2.6-5. Property setting 

Item Setting value Remarks 

Macro_filename Value=>Histogram_Search.json Select "Value=>" and enter the 

value to the right of "Value=>." 
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2.6.3. Creating the subroutine for getting coordinate information and operating the mouse 

As a post-processing subroutine, create the processing for operating the mouse based 

on the coordinate information acquired from WinActorEye. 

Drag and drop "Subroutine Group" from the Node tab.  

 

 

Figure 2.6-10. Placing the "Subroutine Group" node 

 

Set the property value according to the table below. 

 

Table 2.6-6. Property setting 

Item Setting value Remarks 

Name Get coordinate info and operate mouse  - 
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Add the processing for getting the coordinate information after running the macro for the 

histogram search. 

Drag and drop "Eye_GetCoordinates" from the Library tab. 

 

 

Figure 2.6-11. Placing the "Eye_GetCoordinates" library 

 

Set the property values according to the table below. 

 

Table 2.6-7. Property settings 

Item Setting value Remarks 

Coordinate_resource_name Coordinate_resource_name - 

Index Index - 

Variable_for_x_coordinate x-coordinate - 

Variable_for_y_coordinate y-coordinate - 
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Add the processing for getting the position information of the window of the Tutorial 

page.  

Drag and drop "Window_GetWindowRectangle" from the Library tab. 

 

 

Figure 2.6-12. Placing the "Window_GetWindowRectangle" library 
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Set the property values according to the table below. 

 

Table 2.6-8. Property settings 

Item Setting value Remarks 

WinID name Tutorial - Profile 1 - Microsoft 

Edge 

Select from the drop-down list. 

Upper_left(x) Window_position_x - 

Upper_left(y) Window_position_y - 

Horizontal_width Unused_1 - 

Vertical_height Unused_2 - 
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For the coordinate information after running the macro for the histogram search 

processing and the position information of the window of the Tutorial page, add each of 

the x-coordinate and y-coordinate and calculate the coordinates for operating the 

mouse.  

Drag and drop two "Four Arithmetic Operations" from the Node tab. 

 

 

Figure 2.6-13. Placing two "Four Arithmetic Operations" nodes 
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Set the property values according to the tables below. 

 

Table 2.6-9. Property settings (The first "Four Arithmetic Operations") 

Item Setting value Remarks 

Calculation result x-coordinate Select from the drop-down list. 

Left side of + x-coordinate Select from the drop-down list. 

Operator + Select from the drop-down list. 

Right side of + Window_position_x Select from the drop-down list. 

 

Table 2.6-10. Property settings (The second "Four Arithmetic Operations") 

Item Setting value Remarks 

Calculation result y-coordinate Select from the drop-down list. 

Left side of + y-coordinate Select from the drop-down list. 

Operator + Select from the drop-down list. 

Right side of + Window_position_y Select from the drop-down list. 
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Add the processing of moving the mouse pointer to the acquired coordinates. 

Drag and drop "Mouse_MovePointer" from the Library tab. 

 

 

Figure 2.6-14. Placing the "Mouse_MovePointer" library 
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Set the property values according to the table below. 

 

Table 2.6-11. Property settings 

Item Setting value Remarks 

Coordinate_specification Absolute_coordinate Select from the drop-down list. 

X-coordinate x-coordinate Select from the drop-down list. 

Y-coordinate y-coordinate Select from the drop-down list. 
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Add the processing of clicking the mouse after moving the mouse pointer. 

Drag and drop "Mouse_ClickLeftButton" from the Library tab. 

 

 

Figure 2.6-15. Placing the "Mouse_ClickLeftButton" library 

 

Set the property value according to the table below. 

 

Table 2.6-12. Property setting 

Item Setting value Remarks 

Mouse_operation Left_click Select from the drop-down list. 
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Set variables in such a way that the scenario is to be operated. 

Select [View] > [Variable list] from the WinActor menu to display the "Variable list" pane. 

Set the initial values according to the table below.  

 

 

Figure 2.6-16. Setting the initial values 

 

Table 2.6-13. Property settings 

Variable name Initial value Remarks 

Processing_result OK Enter in half-width 

characters 

Coordinate_resource_name Coordinate resource output - 

Index 0 Enter in half-width 

characters 

 

  
















































































